Quick Start Lessons
Note:

You should copy the lesson files contained in the
Bentley\HAMMER8\Lessons directory to a working folder before
working with or modifying them. This will preserve the integrity
of the original files and circumvent potential problems with
administrative write permissions in the product directories.

Bentley HAMMER is a very efficient and powerful tool for simulating hydraulic
transients in pipelines and networks. The quick-start lessons give you hands-on
experience with many of Bentley HAMMER's features and capabilities. These detailed
lessons will help you to explore and understand the following topics:
1. Pipeline Protection using Bentley HAMMER—by assembling a pipeline using
the graphical editor and performing two hydraulic transient analyses; without
protection and with protection.
2. Network Risk Reduction using Bentley HAMMER—by opening a water
distribution network model created in Bentley WaterGEMS and performing a
hydraulic transient analysis using advanced surge protection and presentation
methods.
Another way to become acquainted with Bentley HAMMER is to run and
experiment with the sample files, located in the \Bentley\HAMMER8\Samples
folder. Remember, you can press the F1 key to access the context-sensitive help at
any time.

Lesson 1: Pipeline Protection
In this lesson, you will use Bentley HAMMER to perform a numerical simulation of
hydraulic transients in a water transmission main and, based on the results of your
analysis, recommend suitable surge-protection equipment to protect this system from
damage. You can do this in three steps:
1. You need to analyze the system as it was designed (without any surge-protection
equipment) to determine its vulnerability to transient events.
2. You can select and model different surge-protection equipment to control
transient pressures and predict the time required for friction to attenuate the
transient energy.
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3. You can present your results graphically to explain your surge-control strategy
and recommendations for detailed design.
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Part 1—Creating or Importing a Steady-State Model
You can create an initial steady-state model of your system within Bentley HAMMER
directly, using the advanced Bentley HAMMER Modeler interface, or import one
from an existing steady-state model created using other software. In this lesson, you
will assemble a hydraulic transient model using both methods to learn their respective
advantages and note the similarities between them.

Creating a Model
Bentley HAMMER is an extremely efficient tool for laying out a water-transmission
pipeline or even an entire distribution network. It is easy to prepare a schematic model
and let Bentley HAMMER take care of the link-node connectivity and element labels,
which are assigned automatically. For a schematic model only pipe lengths must be
entered manually to complete the layout. You may need to input additional data for
some hydraulic elements prior to a run.
Note: Regardless of the screen coordinates entered or displayed in the
element editor, if the “Has User Defined Length?” property is
set to True, Bentley HAMMER analyzes the system using the
pipe lengths entered.

The water system is described as follows: a water-pumping station draws water from a
nearby reservoir (383 m normal water level) and conveys 468 L/s along a dedicated
transmission pipeline to a reservoir (456 m normal water level) for a total static lift of
456 – 383 = 73 m. The elevation of the constant-speed pump is 363 m and its speed is
1760 rpm. Transmission main data are given in tables Nodes and Elevations and
Link (Pipe) Properties and Steady State HGL. Other data will be discussed below,
as you add or modify each hydraulic element in this system.
To create a hydraulic model using the Bentley HAMMER Modeler interface:
1. Click File > New to start a new project. This starts Bentley HAMMER's graphical
element editor, so you can draw the system by inserting hydraulic elements.
2. Click the Tools menu and select Options. Go to the Drawing tab and change the
Drawing Mode to Schematic.
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3. Go to the Units tab, click the Reset Defaults button and change the Default unit system
for this project to System International.

Click OK.
4. Add a Reservoir element.
a. Click the Reservoir button

on the Layout toolbar.

b. Move the cursor over the drawing pane and click to place the reservoir.
Bentley HAMMER automatically names this element R-1.
c. Double-click the reservoir to open the Properties editor. Rename the reservoir
by entering Res1 in the Label field of the Properties editor dialog. Change the
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Elevation value to 383.00m and the Elevation (Inlet/Outlet Invert) value to
380.00m.

5. Add a Junction element
Elevation to 363.00m.
6. Add a Pump element
to 363.00m.

to the right of Res1 and rename it PJ1. Change the

to the right of PJ1 and rename it PMP1. Change the Elevation

7. Add 7 more Junction elements in a line to the right of PMP1. Rename them and set their
elevations according to the data in the table below:
Nodes and Elevations
Default Label

Rename to

Elevation (m)

J-2

PJ2

363.00

J-3

J1

408.00

J-4

J2

395.00

J-5

J3

395.00

J-6

J4

386.00

J-7

J5

380.00

J-8

J6

420.00

8. Add a Reservoir element to the right of J6. Rename it Res2 and change the
Elevation to 456.00m and the Elevation (Inlet/Outlet Invert) to 453.00m.
Note:

Transient Tip: Elevations are extremely important in hydraulic
transient modeling. This is because slopes determine how fast
water columns will slow down (or speed up) as their momentum
changes during a transient event. Therefore, defining the profile
of a pipeline is a key requirement prior to undertaking any
hydraulic transient analysis using Bentley HAMMER.

9. Add pipes connecting each of the node elements. Click the Pipe button
Layout toolbar. a. Click Res1.

on the

b. Click PJ1.
c. Click PMP1.
d. Continue clicking each node in turn from left to right.
e. After you've clicked Res2, right-click and select Done to finish laying out the pipe.
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10. When editing data for a large number of elements, it can be more convenient to do
so using FlexTables. Click the View menu and select the FlexTables command. In
the FlexTables Manager, double-click Pipe Table.

11. In the FlexTable, you can edit white fields only; yellow fields are read-only. When
all of the elements in the table should have the same value for an attribute, you can
globally edit them to set them all at once. Right-click the Diameter column and
select Global Edit. Leave the Operation at Set and enter 600.00 as the value. Click
OK.

Bentley HAMMER V8i Edition User’s Guide

2-7

Lesson 1: Pipeline Protection
12. Right-click the Has User Defined Length? column and select Global Edit. Leave
the Operation at Set and place a check in the Value box, then click OK.
13. Enter data for each of the pipes using the data in the table below. You can use the
Global Edit function to enter the Wave Speed.
Link (Pipe) Properties and Steady State HGL
Default Label

Rename To

Length (User
Defined) (m)

Diameter
(mm)

Wave Speed
(m/s)

P-1

PS1

50

600

1200.00

P-2

PMP1S

40

600

1200.00

P-3

PMP1D

10

600

1200.00

P-4

P1

20

600

1200.00

P-5

P2

380

600

1200.00

P-6

P3

300

600

1200.00

Link (Pipe) Properties and Steady State HGL
Default Label

Rename To

Length (User
Defined) (m)

Diameter
(mm)

Wave Speed
(m/s)

P-7

P4

250

600

1200.00

P-8

P5

400

600

1200.00

P-9

P6

250

600

1200.00

P-10

P7

175

600

1200.00

14. After you have finished editing the data, close the FlexTable. The final piece of
element data we need to define is the pump definition. Click the Components menu
and select Pump Definitions.
15. Click the New button to create a new pump definition. Under Pump Definition
Type select Design Point (1 Point). Enter a value of 468 L/s for the Design Flow
and 81.30m for the Design Head. Click the Close button.
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16. Highlight pump PMP1. In the Properties Editor click the Pump Definition field and
select Pump Definition - 1 from the list.
17. In the drawing view, some of the elements and element labels may overlap,
obscuring one another. You can reposition element labels. Zoom in on an element
label and click on it. If done correctly, only the label will be highlighted; if the
element and label are highlighted, try clicking again. When the element label is
highlighted, a dot will appear near the highlighted label; this is called the label's
grip.

18. Click on the grip, hold down the mouse button, and move it to the desired location,
then let go of the mouse button. Reposition the labels so that all of them are visible.
When you are finished the model should look like this:
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19. We can now calculate the steady-state initial conditions of the model. Click the
Compute Initial Conditions button.
20. Close the Calculation Summary window and the User Notifications window.
21. Click File > Save As to select a directory and save your file with a name such as
Lesson1.wtg.

Part 2—Selecting the Transient Events to Model
Any change in flow or pressure, at any point in the system, can trigger hydraulic
transients. If the change is gradual, the resulting transient pressures may not be severe.
However, if the change of flow is rapid or sudden, the resulting transient pressure can
cause surges or water hammer. Since each system has a different characteristic time,
the qualitative adjectives gradual and rapid correspond to different quantitative time
intervals for each system.
There are many possible causes for rapid or sudden changes in a pipe system,
including power failures, pipe breaks, or a rapid valve opening or closure. These can
result from natural causes, equipment malfunction, or even operator error. It is
therefore important to consider the several ways in which hydraulic transients can
occur in a system and to model them using Bentley HAMMER.
Note: Transient Tip: If identifying, modeling, and protecting against
several possible hydraulic transient events seems to take a lot
of time and resources, remember that it is far safer and less
expensive to learn about your system's vulnerabilities by
"breaking pipes" in a computer model—and far easier to clean
up—than from expensive service interruptions and field repairs.

In this lesson, you will simulate the impact of a power failure lasting several minutes.
It is assumed that power was interrupted suddenly and without warning (i.e., you did
not have time to start any diesel generators or pumps, if any, prior to the power
failure). The purpose of this type of transient analysis is to ensure the system and its
components can withstand the resulting transient pressures and determine how long
you must wait for the transient energy to dissipate.
For many systems, starting backup pumps before the transient energy has decayed
sufficiently can cause worse surge pressures than those caused by the initial power
failure. Conversely, relying on rapid backup systems to prevent transient pressures
may not be realistic given that most transient events occur within seconds of the
power failure while isolating the electrical load, bringing the generator on-line, and
restarting pumps (if they have not timed out) can take several minutes. (See Part 3—
Configuring the Bentley HAMMER Project.)
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Part 3—Configuring the Bentley HAMMER Project
Before running the Bentley HAMMER model you have created in Part 1, you need to
set certain run-time parameters such as the fluid properties, piping system properties,
run duration, and output requirements.
1. Click the Analysis menu and select Calculation Options.
2. In the Calculation Options manager, double-click Base Calculation Options under
Transient Solver.
3. The Properties editor will now display the Calculation Options attributes for the
highlighted calculation options profile. Change the Report Points attribute value to
Selected Points.
4. Click the ellipsis button (...) in the Report Points Collection field.
5. In the Report Points Collection dialog, double-click P1 / J1, P2 / J1, PMP1S/ PMP1, and
PMP1D/PMP1 in the Available Items list to add them to the Selected Items list. Click OK.

This will output the transient history (or temporal variation of flow, head, and air
or vapor volumes) at the pump and nearby nodes (you can also add other points
of interest, such as P7 / Res2).
6. Change the Run Duration Type to Time.
7. Enter a Run Duration (Time) value of 140 seconds.
8. Change the Pressure Wave Speed to 1250 m/s.
Note:

Transient Tip: Wave speed is a key parameter in transient
analysis. Assigning pressure wave speeds to individual pipes
will override the wave speed set as a global parameter in the
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System tab. When the pipe's wave speed is blank (or 0.0), then
the global wave speed is used for that pipe.

9. Leave the Vapor Pressure value at the default value of -97.9 kPa.
10. Change the Generate Animation Data field to True.
11. Close the Calculation Options manager.
12. Report Paths are created through the Profile Manager. Click the View menu and select
Profiles.
13. In the Profiles manager, click the New button.
14. In the Profile Setup dialog click the Select From Drawing button.
15. You will be returned to the drawing view; click PMP1 and then Res2 - all the intermediate
points should be selected automatically. Then right-click and select Done (or click the
checkmark button in the Select toolbar).
16. In the Profile Setup dialog, click the Open Profile button.

17. In the Profile Series Options dialog that appears, click OK to accept the default profile
settings.
18. Check that the profile looks like the one below, then close the Profile.
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19. In the Profiles manager, highlight the newly created profile Profile - 1 and click the
Rename button. Enter the name Main Path. The hammer symbol in the upper right of the
profile icon indicates that this profile is a Transient Report Path, meaning that during a
transient analysis results will be saved for this profile.
20. Close the Profiles manager.

21. Save the file with the same name (Lesson1.wtg) using File > Save. You are now ready to
run a transient analysis. (See Part 4—Performing a Transient Analysis.)

Part 4—Performing a Transient Analysis
In this section, you will first simulate transient pressures in the system due to an
emergency power failure without any protective equipment in service. After a careful
examination of your results, you will select protective equipment and simulate the
system again using Bentley HAMMER to assess the effectiveness of the devices you
selected to control transient pressures. See Analysis with Surge-Protection
Equipment.
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Analysis Without Surge Protection Equipment
To perform a hydraulic transient analysis of the system after a sudden power failure
without surge protection (other than the pump's check valve):
1. Double-click PMP1. In the Properties editor change the Pump Type (Transient) value to
Shut Down After Time Delay.
2. Set the other pump parameters:
a. Diameter (Pump Valve): Set the inside diameter of the pump's discharge
flange to 600 mm.
b. Time (Delay Until Shutdown): Set this to 5 seconds. For convenience, it is
assumed that the power failure occurs after 5 seconds, so that point histories
will show the initial steady state during this period.
c. Pump Valve Type: set to default (Check Valve). The power failure is assumed
to be instantaneous and the check valve is allowed to close without any delay
(zero) to protect the pump from damage.
3. Click the Pump Definition field and select Edit Pump Definitions.
4. In the Pump Definitions dialog, click the Efficiency tab. Change the Pump Efficiency type
to Constant Efficiency, and the Pump Efficiency value to 85 %.
5. Click the Transient tab. Set the following parameters:
a. Inertia (Pump and motor): This is the combined pump, shaft, and motor
inertia: set it to 17.2 kg - m2. This value can be obtained from the manufacturer
or estimated from its power rating
b. Speed (Full): Set this to 1760 rpm.
c. Specific Speed: Select SI=25, US=1280.
d. Reverse Spin Allowed?: Uncheck this box. Not allowing reverse spin assumes
there is a check valve on the discharge side of the pump or that the pump has a
nonreverse ratchet mechanism.
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6. Close the Pump Definitions dialog.
7. Click the Compute button

to start the transient analysis..

8. When the run is completed, the Transient Calculation Summary opens automatically,
displaying calculation options used during the run, initial conditions, and extreme pressure
and head values.
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9. Click the Close button in the Transient Calculation Summary.
10. Close the User Notifications window.
Reviewing your Results
By default, Bentley HAMMER does not generate output for every location or every
time step, since this would result in very large file sizes (tens or hundreds of
megabytes). For the specific report points or paths (e.g., profiles) you specified prior to
the run, you can generate several types of graphs or animations to visualize the results:
1. HGL Profile: Bentley HAMMER can plot the steady-state hydraulic grade line
(HGL) as well as the maximum and minimum transient head envelopes along the
Main path.
2. Time History: Bentley HAMMER can plot the time-dependent changes in transient
flow, and head and display the volume of vapor or air at any point of interest.
3. Animations: You can animate to visualize how system variables change over time
after the power failure. Every path and history on the screen is synchronized and
animated simultaneously. Note how transient pressures stabilize after a while.
It is important to take the time to carefully review the results of each Bentley
HAMMER run to check for errors and, if none are found, learn something about the
dynamic nature of the water system.
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Click the Analysis menu and open the Transient Results Viewer
the version of the viewer to use you can select either version.

. If prompted for

Profile the Main Path and plot the various time history graphs. Depending on your
viewer version, animate the results by pressing the Play

button.

•

The graph for the Main path shows that a significant vapor cavity forms at the
local high point at the knee of the pipeline (i.e., the location where the steep pipe
section leaving the pumps turns about 90 degrees to the horizontal in the pump
station).

•

Viewing the animation a few times shows that a vapor pocket grows at node J1 (as
the water column separates) and subsequently collapses due to return flow from
the receiving reservoir Res2. The resulting transient pressures are very sudden and
they propagate away from this impact zone, sending a shock wave throughout the
pipeline.

•

The time history at the pump shows that the check valve closes before these
pressure waves reach the pump (zero flow), effectively isolating it from the system
and protecting it against damage.

Analysis with Surge-Protection Equipment
Certain protective equipment such as a hydropneumatic tank (also known as a gas
vessel or air chamber), combination air valve or CAV (also known as a vacuumbreaker
and air-release valve), or a one-way surge tank can be installed at local high points to
control hydraulic transients.
Note: Adding surge-control equipment or modifying the operating
procedures may significantly change the dynamic behavior of
the water system, possibly even its characteristic time.
Selecting appropriate protection equipment requires a good
understanding of its effect, for which Bentley HAMMER is a
great tool, as well as the good judgment and experience you
supply.

It is clear that high pressures are caused by the sudden collapse of a vapor pocket at
node J1. You could install a Hydropneumatic Tank at junction J1 to supply flow into
the pipeline upon the power failure, keeping the upstream water column moving and
minimizing the size of the vapor pocket at the high point (or even preventing it from
forming). You can test this theory by simulating the system again using Bentley
HAMMER and comparing the results with those of the unprotected run:
1. Click the Hydropneumatic Tank button

on the Layout toolbar.

2. Click on J1. A prompt will appear, asking if you'd like to morph J1 into a Hydropneumatic
Tank element. Click Yes.
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3. Set the Hydropneumatic Tank element properties in the Properties editor:
a. Make sure the Elevation (Base) and the Elevation are set to 408.000 m.
b. Set the Operating Range Type to Elevation.
c. Set the HGL (Initial) to 465 m.
d. Set the Liquid Volume (Initial) to 14200 L.
e. Set the Minor Loss Coefficient (Outflow) to 1.0.
f.

Set the Tank Calculation Model to Gas Law Model.

g. Set the Volume (Tank) to 20000 L.
h. Set the Treat as Junction? field to True. This means that the hydropneumatic tank is not
included in the calculations of initial conditions. Instead the HGL in the
hydropneumatic tank is assumed to be the same as if there was a junction at the tank
location.
i.

Set the Diameter (Tank Inlet Orifice) to 450 mm.

j.

Set the Ratio of Losses to 2.5.

k. Set the Gas Law Exponent to 1.2.
l.

Set the Has Bladder? field to True.

m. Set the Pressure (Gas-Preset) to 0.0.
4. Now we must update our report points and report path to reflect the replacement of J1 with
HT-1. Click Analysis > Calculation Options and double-click the Base Calculation
Options under the Transient Solver.
5. Click the ellipsis button in the Report Points Collection field.
6. Add P1 / HT-1 and P2 / HT-1 to the Selected Items list. Click OK.
7. Click View > Profiles and Edit the Main Path Profile. Click Yes when prompted to autorepair the profile. The profile will open and will now include the hydropneumatic tank.
Close the Profile and the Profiles manager.
8. Select File > Save As and save the file with a new name: Lesson1_Protection.wtg.
Note:

Rather than editing the original model and saving it as a new
file, a better way is to create a new scenario in the original
model for the transient protection simulation. We will investigate
scenarios in Lesson 2.

9. Click the Compute Initial Conditions button. Close the Calculation Summary and the User
Notifications dialog.
10. Click the Compute button. Close the Transient Calculation Summary and the User
Notifications dialog.
11. Click the Analysis menu and select Transient Results Viewer.
12. Click the Profile button on the Profiles tab.
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As you can see, installing a Hydropneumatic Tank at node J1 has significantly
reduced transient pressures in the entire pipeline system. Due to this protection
equipment, no significant vapor pocket forms at the local high point. However, it is
possible that a smaller tank could provide similar protection.
It is also possible that other protection equipment could control transient heads and
perhaps be more cost-effective as well. Before undertaking additional Bentley
HAMMER simulations, it is worthwhile to compare and contrast the results with or
without the Hydropneumatic Tank.
See Part 5—Animating Transient Results at Points and along Profiles.

Part 5—Animating Transient Results at Points and along Profiles
Bentley HAMMER provides many ways to visualize the simulated results using a
variety of graphs and animation layouts. You must specify which points and paths
(profiles) are of interest, as well as the frequency to output prior to a run, or Bentley
HAMMER will not generate this output to avoid creating excessively large output
files. For small systems, you can specify each point and every time step, but this is not
advisable for large water networks.
For the same reason, Bentley HAMMER only generates the Animation Data (for onscreen
animations) if you select this option in the transient calculation options.
Note:

To achieve shorter run times and conserve disk space, try to
avoid generating voluminous output, such as Animation Data or
Output Databases, at an early stage of your hydraulic transient
analysis. Fast turnaround makes your evaluation of different
alternatives more interactive and challenges you to apply good
judgement as you compare your mental model of the system
with Bentley HAMMER's results—a good habit which is like
estimating an answer in your head when using a calculator.

While you are still evaluating many different types or sizes of surge-protection
equipment, you can often compare their effectiveness just by plotting the maximum
transient head envelopes for most of your Bentley HAMMER runs. At any time, or
once you feel you are close to a definitive surge-control solution, you can use Bentley
HAMMER to generate the animation data files by setting Generate Animation Data to
True in the Transient Calculation Options. After the run, you can open the Transient
Results Viewer from the Analysis menu.
Note:

Once you have generated the animation data files, you will be
able to display animations without running the HAMMER V8i
simulation again. This saves a lot of time when comparing the
results of several surge-control alternatives.

1. In the Transient Results Viewer, on the Profiles tab, select:
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–

Profile: Main

–

Graph Type: Hydraulic Grade and Air/Vapor Volume

2. Click the Animate button. This loads the animation data and Animation Control.
3. On the Animation Controller, click the play button to start the animation.

Part 6—Viewing Time History Graphs in Bentley HAMMER
Using the Bentley HAMMER Transient Results Viewer, you can plot a transient
history at any point in the system to display the temporal variation of selected
parameters (such as pressures and flow).
1. Click the Analysis menu and select Transient Results Viewer.
2. In the Time Histories tab, select:
–

Time History: P1:HT-1

–

Graph Type: Hydraulic Grade, Flow, and Air/Vapor Volume

3. Click Plot to display this transient history.
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4. To view numerical data for the time history, click the Data tab. From here, you can sort the
data by right-clicking on the column header and choosing Sort. You can also change the
units and precision for the results by right-clicking on the column header and choosing
Units and Formatting.

Click OK to save these settings and leave the FlexUnits Manager. From now on, Head
will be displayed in ft. and Flow will be displayed in l/s.
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In Lesson 1, you learned how to create and run a simple pipeline model and explored
its different characteristics using Bentley HAMMER. In this lesson, you will import a
simple water-distribution network connected to the same pipeline introduced in
Lesson 1. You will then perform a more advanced hydraulic transient analysis, again
in three steps:
1. Import the steady-state WaterCAD model into Bentley HAMMER and verify it.
2. Select a transient event to analyze and run the Bentley HAMMER model.
3. Annotate and color-code the resulting map, profiles, and time histories using
Bentley HAMMER's powerful, built-in visualization capabilities.

Part 1—Importing and Verifying the Initial Steady-States
Follow these steps to open the Bentley HAMMER model:
1. Click File > Open. Browse to the C:\Program Files
(x86)\Bentley\HAMMER8\Lessons folder and open the file
Lesson2_WaterGEMS.wtg. HAMMER uses the same file format as WaterCAD
and WaterGEMS, so it is possible to open a WaterCAD or WaterGEMS file
directly in HAMMER.
2. Click the Compute Initial Conditions button. Close the User Notifications window.

Inspecting the steady-state model results using Bentley HAMMER reveals that the
water transmission main now carries only 210 L/s of water from the pumping
station to reservoir Res2 at elevation 456 m. A local main takes water from the
transmission main at a tee located about 400 m from the pumping station,
distributing 265 L/s to a nearby subdivision. The part of the subdivision close to
the pumping station has lower ground (and therefore water main) elevations,
while the far end has higher ground elevations. Your goal is to identify transient
issues for this system and recommend surge protection alternatives.

3. Prior to running the transient analysis of this system, you need to select some profiles
and points of interest.
4. Click Analysis > Calculation Options. Double-click on Base Calculation Options
under Transient Solver. Click the ellipsis button in the Report Points Collection
field. Add nodes PMP1D:PMP1, P1:J1, P2:J1, P2:J2, P8:J2, P27:J19, P28:J19,
P47:J34, and P50:J37 to the Selected Items list (you learned how to do this in
Lesson 1).

Click OK.
Note:

Bentley HAMMER plots time histories at a pipe's end points,
defined as the point on a pipe closest to a node and labeled
Pipe_End_Point:Node. To obtain a complete picture of what is
occurring at any given node, you must inspect every end point
connected to that node (e.g., in this example, plot histories at end
points P1:J1 and P2:J1 for node J1).

5. Change the Run Duration value to 160 seconds.
6. Set the Specify Initial Conditions field to False. This means that the initial conditions
for the transient simulation (flows, head, etc.) will be computed by the software,
not entered manually by the user. Close the Calculation Options window.
7. Click the View menu and select Profiles.
8. Create three new profiles as follows:
–

Create a profile named Path1 and add pipes PMP1D, P1, P2, P3, P4, P5, P6,
and P7 to it.

–

Create a profile named Path2 and add pipes PMP1D, P1, P2, P8, VLV1U,
VLV1D, P9, P10, P14, P48, P49, and P50 to it.

–

Create a profile named Path3 and add pipes PMP1D, P1, P2, P8, VLV1U,
VLV1D, P9, P15, P22, P24, P28, P30, P46, and P47 to it.

9. Close the Profiles manager.
10. Click the Compute Initial Conditions button. Close the Calculation Summary.
Note:

You can set HAMMER to always compute the initial conditions
prior to computing a transient simulation. To do this click the
Analysis menu and then click Always Compute Initial Conditions.

11. Click the Compute button. Close the Transient Calculation Summary.
12. Click the Analysis menu and select Transient Results Viewer. To view a plot of
the maximum and minimum head envelopes along Path1, Path2, and Path 3,
choose the profile from the pulldown and select Profile. The envelopes along
Path1 should look like the following figure.

13. To generate a plot of the hydraulic transient history at the pumping station, select
the Time History tab in the Transient Results Viewer. To see hydraulic grade and
flow results, choose Time History: PMP1D:PMP1 and Graph Type: Hydraulic
Grade, Flow and Air/Vapor Volume. There should be no significant change in the
steady-state conditions with time.
Results from the Bentley HAMMER run you have just completed do not show any
change in the steady-state heads and flows throughout the water network as time
passes. This indicates the calculated initial conditions can be considered as valid. You
are now ready to proceed with the hydraulic transient analysis for this network.
If the solution tolerance of a steady-state model is too coarse, Bentley HAMMER's
highly accurate model engine may report transients at time zero in the Transient
Analysis Output Log file (found under Report > Transient Analysis Reports). This can
usually be handled by running the steady-state model again with a smaller error
tolerance (set under Analysis > Calculation Options > Steady State / EPS Solver >
Base Calculation Options > Accuracy).

Part 2—Selecting the Key Transient Events to Model
In Lesson 1, you simulated the transient pressures resulting from a sudden power
failure. In this lesson you will learn how to simulate transient pressures in a water
distribution network triggered by an emergency pump shutdown and restart. Although
a power failure often results in the worst-case conditions, restarting before friction has
dissipated the transient energy can cause higher extreme pressures than the initial
power failure.

Part 3—Performing a Transient Analysis
In order to generate transient events for a rapid but controlled emergency pump
shutdown and restart, you need to set appropriate pump characteristics to control the
speed at which this pump can shut down and restart. One of the ways to do this is to
use a variable-frequency drive (VFD), also known as a variable-speed pump.

Analysis without Surge Protection
1. Double-click PMP1. In the Properties Editor, under Transient (Operational)
properties, change the Pump Type (Transient) value to Variable Speed/Torque.
2. You can use either Speed or Torque to control the VFD pump ramp times. In this
lesson, you will learn how to control the pump using Speed (i.e., Control Variable
set to Speed).
3. Under Transient (Operational) properties, click the Operating Rule drop-down list
and select <Edit...>. The Patterns manager opens.
4. Highlight the Operational (Transient, Pump) folder and click the New button. In the
Pattern tab on the right side of the dialog, click the New button to add a new row to
the pattern table. Enter a value of 1 for Multiplier at 5.0 seconds Time from Start.
Fill in the rest of the table as indicated. This pattern will slow the pump linearly
from full speed at 5 seconds into the simulation to zero speed at 10
seconds into the simulation. Then at 25 seconds into the simulation the pump will
start to speed up linearly from zero to reach full speed at 30 seconds. Close to leave
the Patterns manager.

5. In the Pump Properties, under Transient (Operational), click the Operating Rule
drop-down list and select Operational (Transient, Pump) - Pattern 1.
6. Click Analysis > Calculation Options. Double-click Base Calculation Options under
Transient Solver. Change the Generate Animation Data field value to True. You
will need the animation data later to animate the results on screen. Close the
Calculation Options manager.
7. Click the Compute button. Close the Transient Calculation Summary and User
Notifications windows.
8. Click the Analysis menu and select Transient Results Viewer.
9. Plot the Time History for Hydraulic Grade, Flow, and Air/Vapor Volume at end
point PMP1D:PMP1 (i.e., the discharge side of the pump). It should look like the
following figure and have these characteristics:
–

After the emergency pump shutdown, pressure and flow drop rapidly,
followed by a large upsurge pressure (at about 15 s) after flow returning to the
pumping station collapses the vapor pockets at the high points. The check
valve on the discharge side of the pump keeps the flow at zero during the
initial and subsequent pressure oscillations (until the pump restarts).

–

The maximum transient head resulting from the pump restart does not exceed
the maximum head reached about ten seconds after the initial power failure.

This is because flow supplied by the pump prevents vapor pockets from
reforming and collapsing again.
–

The system approaches a new steady state after 50 seconds and it has
essentially stabilized to a new steady state by 90 seconds.

–

As expected, the final steady state is similar to the initial steady state.

10. Plot the Hydaulic Grade and Air/Vapor Volume to see the maximum and
minimum transient head envelopes along Path1, Path2, and Path3. The Path3
envelopes should look like the following figure:

In these figures,
–

Subatmospheric transient pressures occur in almost half of the pipeline. Full
vacuum pressure (–10 m) occurs at the knee of the pipeline (near the pump
station) and at the local high point in the distribution network.

–

Maximum transient pressure heads are of the order of 100% above steadystate
pressures along the majority of Path3. This is likely very significant compared
to the pipes' surge-tolerance limit, especially if the network contains older
pipes. It would be useful to show the pipe's working pressure and surgetolerance limit on the paths to assess whether it can withstand these high
pressures.

11. Experiment to learn the sensitivity of this system to an automatic, emergency
shutdown and restart:
–

Set different shutdown and restart ramp times for the pump. For example, try
10 s ramp times for the pump. How fast does the flow decrease to zero? Why?

–

Select different time delays between the pump shutdown and restart. What
happens if you try to restart the pump when pressure is rising, or at its lowest,
or highest point?

12. Identify the fastest ramp times and shortest time delay which do not result in
unacceptable transient pressures anywhere in the system. Since the maximum
transient envelopes depend on these two variables, several valid solutions are
possible. You can document your solution in the operations manuals for the
pumping station and verify its accuracy upon commissioning.

Note:

The volume of vapor or air reported at a node is the sum of the
volumes at every end point of all connected nodes. Since a pipe
may have volumes elsewhere than at its end point, node and
pipe volumes may not match. If more than two pipes connect to a
node, the volume reported on a path (or profile) plot may not
match the volume reported for that node's history, or in the
Drawing Pane, because a path can only include two of the pipes
connecting to that node.

13. The results indicate that significant pressures occur in the system. After viewing
the animations, it becomes even more clear that:
–

High pressures result from the collapse of significant vapor pockets at local
high points. Inspection of the transient histories at end-points P2:J1 and
P27:J19 confirms that vapor pockets collapse at around these times.

–

The pump restarts at 25 s or 20 s after the start of the emergency pump
shutdown, just as the high-pressure pulse from the collapse of a vapor pocket
at node J1 is reaching the pump station. This pulse closes the check valve
against the pump for a while, until it reaches its full speed and power at
around 30 s.

–

Transient pressure waves travel throughout the system, reflecting at
reservoirs, dead-ends, and tanks. This results in complex but essentially
periodic disturbances to the pump as it attempts to re-establish a steady state.

–

As expected, the final steady-state head and flow are similar to the initial
steady state.

Analysis with Surge-Protection Equipment
You can select from an array of protective equipment to control high and low transient
pressures in the pipeline (Path1) and distribution network (Path2 and Path3). Using
Bentley HAMMER, you can assess the efficiency of alternative protection equipment,
noting how protection for the pipeline affects conditions in the network and vice
versa. In this example you will try to protect this entire system with two surge-control
devices:
• A Hydropneumatic Tank at node J1 similar to the protection used in Lesson 1.
• A simple flow-through surge tank or standpipe at the node J19. A combination air
valve could also be considered for this location if freezing or land-acquisition
costs are a concern.
The model has already been set up to use the new protection equipment using the
Active Topology Alternative. In the drawing, you'll notice grey pipes and nodes
adjacent to the J1 and J19 areas.

Active Topology is a way to model multiple network layouts in the same model. You
can mark elements as Inactive for certain scenarios, but Active in others.
We will create a new Active Topology Alternative in which the new Hydropneumatic
Tank and Surge Tank (and their adjoining pipes) are Active and the elements they are
replacing (J1 and J19 and their adjoining pipes) are Inactive.
1. Click the Analysis menu and select Alternatives.
2. In the Alternatives manager, expand the Active Topology node, right-click the Base
Active Topology alternative and select New > Child Alternative. Rename the new
alternative With Protection.

3. Close the Alternatives manager. Click the Analysis menu and select Scenarios. Click
the New button and select Child Scenario. Name the new scenario With Protection.

4. Double-click the new scenario to open the Properties editor and change the Active
Topology Alternative to With Protection. In the Scenarios manager, make sure the
With Protection scenario is highlighted, and then click the Make Current button.
With the new scenario active, any edits made to the active topology will only affect
the new With Protection scenario (and by extension the With protection Active
Topology alternative).
5. Click the Tools menu and select Active Topology Selection. The Active Topology
Selection toolbar appears.

6. The Add button makes elements Inactive.
7. The Remove button makes elements Active.
8. With the Add button toggled on, click on the following elements to make them
Inactive in the drawing pane: J1 and J19.
9. Click the Remove button and click on the following elements to make them Active in
the drawing pane: P1-1, HT-1, P2-1, ST-1, P25-1, P24-1, P26-1, P27-1, and P28-1.

10. The network should now look like this:

11. Click the Done button in the Active Topology Selection toolbar.
12. Since we are using different elements we need to update our report points and
report paths (profiles).
a. In the Transient Solver Base Calculation Options, under the Report Points
Collection, add P1-1:HT-1 and P2-1:HT-1. P1:J1 and P2:J1 are now inactive
so there will be no results to show for those node, however you can leave
them on the list in case you recomputed the Base scenario again.
b. The existing profiles now contain inactive elements, so no results will be
shown for them under the With Protection scenario. Therefore create three
new profiles as follows:
- Create a profile named Path 1- Protection and add pipes PMP1D, P1-1, P2-1,
P3, P4, P5, P6, and P7 to it.

- Create a profile named Path 2 - Protection and add pipes PMP1D, P1-1, P21, P8, VLV1U, VLV1D, P9, P10, P14, P48, P49, and P50 to it.
- Create a profile named Path 3 - Protection and add pipes PMP1D, P1-1,
P2-1, P8, VLV1U, VLV1D, P9, P15, P22, P24-1, P28-1, P30, P46, and
P47 to it.
c. Close the Profiles manager.
13. Click the Compute Initial Conditions button. Close the Calculation Summary.
14. Click the Compute button. Close the Transient Calculation Summary and User
Notifications windows.
15. Once the run completes click the Analysis menu and select Transient Results
Viewer. Use the Profile button to generate graphs of the transient head envelopes
for Path 1 - Protection, Path 2 - Protection, and Path 3 - Protection. The envelope
along Path 3 - Protection should look like the following figure:

–

No subatmospheric pressures occur anywhere in the distribution network
(along Path 3 - Protection).

–

High transient pressures are comparable to the steady-state pressures for the
downstream half of Path 3 - Protection. Keeping transient water pressures
within a narrow band reduces complaints and it could be important for certain
industries.

16. Compare the transient head envelopes and transient histories for Bentley
HAMMER runs with different parameters, without and with protection:

–

You may be able to reduce the size (and cost) of the Hydropneumatic Tank
and Surge Tank by changing their parameters until surge pressures are
unacceptable (for example, try a Hydropneumatic Tank with a volume of
5000 L).

–

Instead of the Hydropneumatic Tank and Surge Tank, you can also try
installing a two-way or "combination" Air Valve at nodes J1 and J19.

17. Before recommending a surge-protection strategy for this system, you need to
perform a transient analysis of an emergency power failure and other possible
transient events.

Part 4—Color-Coding Maps, Profiles, and Point Histories
In the design of a surge-control strategy for a water distribution network, the extreme
states are usually of the greatest interest. Bentley HAMMER has built-in capabilities
to visualize maximum and minimum simulated flows, heads, pressures, and volumes
(vapor or air) throughout the pipe system. You can color-code nodes and pipes
according to these different parameters.
In this part of the lesson, you will learn how to use Bentley HAMMER's color-coding
features to make your presentation more intuitive and compelling to your audiences.
1. In Bentley HAMMER, click File > Open and open the file
Lesson2_WaterGEMS_Finished.wtg.
2. Click the Compute Initial Conditions button. Close the Calculation Summary.
3. Click the Compute button. Close the Transient Calculation Summary and User
Notifications windows.
4. Click the Analysis menu and select Transient Thematic Viewer. By default,
Bentley HAMMER uses Maximum Head results for both the pipes and nodes for
color-coding.
5. On the Pipes tab click the Calculate Range button and select Full Range. This
automatically populates the Minimum and Maximum values for the currently
selected Field Name.
6. In the right side of the window click the Initialize button. Initialize automatically
breaks the range between the maximum and minimum values into the number of
specified steps and assigns a color to each.
7. Click the Ramp button. Ramp chooses colors to make a gradient between the first
and last colors used. Click the third color box and select yellow. Click the 4th
color box and select orange.
8. Click the Use Gradient checkbox in the lower left. When this option is selected,
HAMMER will color code segments within pipes individually, rather than using a
single color for each pipe. Your Pipe tab should now look like this.

9. Click the Apply button and minimize the Transient Thematic Viewer. Your
network should now look like this:

10. In the Transient Thematic Viewer click the Nodes tab. Change the Field Name to
Pressure (Maximum Transient).
Click OK.
11. Click the Calculate Range button and select Full Range.
12. Click the Initialize button. Click the color box in the first row and select a light
blue color. Click the color box in the last row and select a dark blue. Click the
Ramp button. The dialog should now look like this:

13. Click the Apply button. You can minimize the Transient Thematic Viewer, but
don't close it; it must remain open for as long as you want the network elements to
be color coded. Your model should now look like this:

14. Try different variables at pipes and nodes to try to make your presentation more
descriptive. For example, you could try the following:
–

You can change the values that are used in each range. Making the first two
steps encompass a larger portion of the value range will cause more of the
pipes to be colored green, indicating normal to high heads in this system.

–

For pipes, set the percentage corresponding to the dark blue color so that
subatmospheric pressures are displayed in this color, alerting you to potential
pathogen intrusion and heavy pipe or joint pressure cycling.

–

For nodes, experiment with the percentages corresponding to yellow and
orange until they correspond to the pipe's working pressure or surge-tolerance
limit.

Color-coding a map for selected variables provides an overview of extreme conditions
in the entire system. This map can be compared with profiles and histories (or their
corresponding animations).
Some parts in the subdivision also experience high pressures. For example, the
colorcoded map and the Results section of the Element Editor indicate that the point
with the highest elevation in the subdivision, node J34, experiences the lowest

minimum transient pressure, while the lowest point in the network, node J37,
experiences the largest maximum transient pressure.

